More explicit warning about versions mismatch.